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Introduction

Chapter 1  Introduction

The TPSensor® Designer is a development tool that simplifies and accelerates capacitive touch
design using 3PEAK MCU devices. The tool provides a graphical user interface for touch
configuration and parameter tuning.

1.1  Key Features
• Simple graphical user interface for creating, configuring and defining microcontroller connections

for sensors.
• Support for button, slider, and wheel sensors.
• Support for self-capacitive and mutual-capacitive sensor types.
• Real-time plotting of sensor data.
• Real-time tuning of sensor parameters.
• Data logging for further analysis and processing.
• Automated code generation for efficient programming.
• Signal-to-noise ratio (SNR) measurements.

1.2  Software Requirements
Operating Systems Windows® 10 and 11

Screen Resolution Minimum supported resolution is 1200 x 800 pixels.

1.3  Licensing
The TPSensor® Designer is released under the 3PEAK software license. See the license manifest in
the installation directory for details.

1.4  Documentation Conventions
Convention Usage

Bold

Displays commands, menu paths, and icon names in
procedures.
For example:
Click the File icon and then click Open.

File > New
Represents menu path.
For instance:
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Convention Usage

File > New > New Project

Courier New

Displays file locations, user entered text, and source
code.
For example:
<your_sdk_path>/example/tpsensor/
tpsensor_exp/source

Introduction
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Main Window

Chapter 2  Main Window

The TPSensor® Designer main window includes three main parts: Menu Bar, Tool Bar and Design
Area.

Figure 2-1   Main Window

2.1  Main Menu
The main menu bar provides access to the fundamental features and controls of TPSensor®

Designer.

2.1.1  File
The File menu provides the options to create, open, save, and save as project options, detailed in
the table below. Project files are saved in the .tps format.

Figure 2-2   File Menu
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Action Name Shortcuts Description

Open Ctrl+O Click Open and choose a .tps file to access an existing project.

New Ctrl+N
Click New to create a new project.
If the current project is unsaved, the system will prompt you to save
it.

Save Ctrl+S Save the current project, including the device type and related
parameters.

Save As Ctrl+Shift+S Save the current project as a copy.

Exit Alt+F4

Click Exit to close current project and quit the application.
The software displays a pop-up prompt to save the project.

2.1.2  Communication
The Communication menu includes communication interface settings and connection controls.

Figure 2-3   Communication Menu

The Communication menu contains three submenus:

• Connect: Used to establish a connection with the target board. The option grays out when
already connected.

• Disconnect: Disconnect with the target board. The option grays out when already disconnected.
• Settings: Allow configuration of communication interface settings. Currently, the interface only

supports serial port connections.

Figure 2-4 shows the Communication Settings window.

Main Window
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Figure 2-4   Configuration Window for UART

Figure 2-5 shows the configuration Items for UART.

Figure 2-5   UART Configuration Window

2.1.3  Help
Figure 2-6 shows the Help menu.

Figure 2-6   Help Menu

Figure 2-7 displays software copyright and version information.

Main Window
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Figure 2-7   About Pop-Up

2.2  Tool Bar
The toolbar provides:

• Communication interface options
• Connect/disconnect button
• Button group widget button
• Slider widget button
• Wheel widget button
• Proximity widget button

2.3  Design Area
An application utilizing TPSensor® capacitive touch requires an MCU and at least one touch sensor.
Users can add various touch sensors to the design area by clicking the widget button on the toolbar.

Each widget has detail properties and configurable parameters. User click the widget on the left side
of design area, the detailed properties and configurable parameters of the widget are displayed on
the right side.

2.3.1  MCU Properties
The MCU properties panel provides the following features:

• Device configuration
• MCU pins to sensor elements mapping

2.3.1.1    Properties Page
Figure 2-8 shows the properties page, detailed in the table below.

Main Window
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Figure 2-8   MCU Properties Panel

Property Configuration Description

Name
The MCU name can be defined in the Name text box.

Device

Select a MCU device from the drop-down box.

UART

TPSensor® application library requires a UART. Select one from the drop-down
box.

TIMER

TPSensor® application library requires a Timer. Select one from the drop-down
box.

TPSensor® Channel
Assignment

In Pin Assignment tab, users can manually assign the sensor pins to
appropriate pins on the MCU, or click Auto Assign button to automatically do
the assignment.

Main Window
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Property Configuration Description

Figure 2-9   Auto Assign Channel Connections

Figure 2-10   Manual Assign Channel Connections

Click Clear button to clear all connections.

Configuration File
Generation

Click Generate Source Code button, then click Browse to select a folder to
save the generated files, and then click OK.

The generated file can be found in the specified path. These two files include all
hardware connections and sensor parameter configuration information. These
files are used in software project.

Conversion Control

The Conversion Control tab contains the parameter settings for TPSensor®

active mode and sleep mode. Keep the default value if user is unfamiliar with
the setting.

Noise Immunity
The Noise Immunity tab includes the parameter settings for conducted noise
immunity.

Main Window
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Property Configuration Description

2.3.2  Sensor Properties
TPSensor® Designer support Button Group, Slider, and Wheel sensors. Different sensors have
similar properties. This chapter takes button group as an example and introduce the sensor
properties. A button group represents a sensor with multiple buttons, such as keypad.

2.3.2.1    Properties Page
The Button Group sensor properties panel provides below functions:

• Sensor configuration
• Sensor tuning
• Sensor data view

Figure 2-11   Button Group Properties

Property Configuration Description

Name
The sensor name can be customized in the Name text box. This name is
used for code generation.

ID
The ID is generated according to the order the sensor be added. User can
edit the ID value manually. But make sure every sensor has a unique ID
number.

Configuration
Capacitive
Mode

Capacitive Mode specify the sensor type:

Main Window
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Property Configuration Description

• Self

Figure 2-12   Self-Capacitive Mode

• Mutual

Figure 2-13   Mutual-Capacitive Mode

Element
Count

Specify the number of elements for the sensor.

Connection
Topology

Specify TX and RX configuration for the sensor.

Figure 2-14   Connection Topology

2.3.3  Communication
Figure 2-15 shows the communication configuration.

Figure 2-15   Communication Configuration

The configuration section provides two configuration options:

Main Window
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• Connected: Used to enable or disable the connection with the target board and reflect the
connection status.

• Data Logging: Used to log element and sensor data in .csv format.

Main Window
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2.3.4  Data View
View Type GUI Example Description

Image View Display the touch status of the sensor.

Bar View
Display the element data stream in bar view mode.
The Y-axis range can be scaled by the mouse wheel, and the
check box on the right can choose which items to display.

Oscillograph
Display the element data stream in oscilloscope view mode.
The Y-axis range can be scaled by the mouse wheel, and the
check box on the right can choose which items to display.

Main Window
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View Type GUI Example Description

Data Table

Main Window
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2.3.5  SNR
TPSensor® Designer provides a built-in SNR measurement tool which makes it easy to perform an
SNR evaluation of touch design.

2.3.6  Conversion Control
Figure 2-16 shows the Conversion Control configuration page.

Figure 2-16    Conversion Control Tab

2.3.7  Tunning
Figure 2-17 shows the Tunning configuration page.

Figure 2-17   Tunning Panel

Check Advanced to show other parameters.

Main Window
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Software Installation

Chapter 3  Software Installation

3.1  Installation Procedures
1. Double click the installation file appropriate for your operating system.

2. Select an install mode.

3. Read and accept the license agreement, then click Next to continue.
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4. Select an installation folder; the default folder is recommended, and click Next.

5. Create a desktop shortcut if desired.

Software Installation
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6. Complete the installation process.

You can choose to launch TPSensor® Designer immediately after installation, or launch it later by
double-clicking the shortcut on the Desktop.

Software Installation
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Start the TPSensor® Designer

Chapter 4  Start the TPSensor® Designer

This chapter demonstrates using TPSensor® Designer in capacitive touch application development
with EVB and expansion board.

The expansion board has two capacitive touch buttons connected to TPSensor® channels CH8 and
CH9.

Before getting started, connect the expansion board and EVB to your PC with a DAPLink.

4.1  Startup Procedures
1. Double click on the TPSensor® Designer shortcut on the desktop to start the tool.
2. Click File > New to create a new project.

3. Click BtnGrp on tool bar to add a button group sensor to the design area.
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4. Rename button group to myButtonand Set Element Count to 2.

5. Click Conversion Control tab and set Target Baseline to 300.

6. Go back to MCU properties setting window. Assign myButton RX 0 to CH 8 and RX 1 to CH 9.

7. Select UART to USART0 and TIMER to TIMER1.

Start the TPSensor® Designer
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8. Click Generate Source Code, choose save path to <your_sdk_path>/example/tpsensor/
tpsensor_exp/source, and click OK to generate the configuration files.

9. Open the tpsensor_exp example project from the tps325m_sdk example folder.

10.Build the project and download the executable file to the EVB board.

Start the TPSensor® Designer
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11.In TPSensor® Designer, configure the connection parameters.

12.Click the connection icon on the toolbar or check the Connected checkbox of the myButton
properties.

13.Touch the buttons and check the button status.

14.Touch the buttons and check the touch data in bar chart view.

Start the TPSensor® Designer
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15.Touch the buttons and check the touch data in oscilloscope view

16.Touch the buttons and check the raw data.

17.Tune the touch parameters as needed.

Start the TPSensor® Designer
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IMPORTANT NOTICE AND DISCLAIMER
Copyright© 3PEAK 2012-2023. All rights reserved.

Trademarks. Any of the 思瑞浦 or 3PEAK trade names, trademarks, graphic marks, and domain names
contained in this document /material are the property of 3PEAK. You may NOT reproduce, modify, publish,
transmit or distribute any Trademark without the prior written consent of 3PEAK.

Performance Information. Performance tests or performance range contained in this document/material
are either results of design simulation or actual tests conducted under designated testing environment. Any
variation in testing environment or simulation environment, including but not limited to testing method, testing
process or testing temperature, may affect actual performance of the product.

Disclaimer. 3PEAK provides technical and reliability data (including data sheets), design resources
(including reference designs), application or other design recommendations, networking tools, security
information and other resources "As Is". 3PEAK makes no warranty as to the absence of defects, and
makes no warranties of any kind, express or implied, including without limitation, implied warranties as to
merchantability, fitness for a particular purpose or non-infringement of any third-party’s intellectual property
rights. Unless otherwise specified in writing, products supplied by 3PEAK are not designed to be used in any
life-threatening scenarios, including critical medical applications, automotive safety-critical systems, aviation,
aerospace, or any situations where failure could result in bodily harm, loss of life, or significant property
damage. 3PEAK disclaims all liability for any such unauthorized use.
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