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Introduction

Chapter 1  Introduction

TPS32 Programmer is a user-friendly graphical user interface (GUI) tool for programming the on-chip
non-volatile memories of TPS32 devices. It supports both the debug port interface (DAPLink) and the
bootloader interface (UART).

1.1  Key Features
TPS32 Programmer is an all-in-one software tool for programming TPS32 devices. It offers the
following features:

• Configure option bytes
• Read and write image files
• Erase Flash memory
• Modify Flash memory

1.2  Software Requirements
Operating Systems Windows® 10 and 11, 64-bit (x64) or 32-bit (x86)

Screen Resolution Minimum supported resolution is 1200 x 800 pixels.

1.3  Licensing
The TPS32 software is released under the 3PEAK license. See the license manifest in the
installation directory for details.

1.4  Documentation Conventions
Convention Usage

Bold

Displays commands, menu paths, and icon names in
procedures.
For example:
Click the File icon and then click Open.

File > New
Represents menu path.
For instance:
File > New > New Project

Courier New Displays file locations, user entered text, and source
code.
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Convention Usage

For example:
<your_sdk_path>/example/tpsensor/
tpsensor_exp/source

Introduction
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Main Window

Chapter 2  Main Window

Upon initiating the software, the Option Byte configuration page will be displayed.

The main window includes the components described in the subsequent sections.

Figure 2-1   Main Window

2.1  Main Menu
Figure 2-2 shows the main menu.

Figure 2-2   Main Menu
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2.1.1  File
Figure 2-3 shows the File menu.

Figure 2-3   File Menu

To exit the application, click File > Exit.

2.1.2  Communication
Figure 2-4 shows the Communication menu.

Figure 2-4   Communication Menu

This menu has three submenus:

• Connect: Used to establish connection with the target board. This option will be grayed out when
target board has been already connected.

• Disconnect: Used to disconnect from the target board. This option will be grayed out when target
board has been already disconnected.

• Settings: Used to configure UART parameters.

Main Window
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Figure 2-5 shows the Communication Window for UART.

Figure 2-5   Configuration Window for UART

Figure 2-6 shows the configuration parameters for UART.

Figure 2-6   Configuration Parameters for UART

2.1.3  Help
Figure 2-7 shows the Help menu.

Main Window
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Figure 2-7   Help Menu

This menu displays the software version and copyright information.

2.2  Tool Bar
Figure 2-8 shows the tool bar. The tool bar has two items, a combo box is used to select the
communication way, and a button is used to connect/disconnect the target board.

Main Window
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Figure 2-8   Tool Bar

2.2.1  Connection Mode
Figure 2-9 shows the connection mode.

Figure 2-9   Connection Mode

• UART: Connect the target board using the serial port.

NOTE: When the RDP level is not equal to 0 (0xAA), all operations via the UART connection
are prohibited.

• DAPLink: Connect the target board using the CMSIS DAPLink with OpenOCD.

2.2.2  Connect Button
Figure 2-10 shows the connect button.

Main Window

www.3peak.com 8 / 20 UGST0008A00E



Figure 2-10   Connect Button

To connect or disconnect with the target board, toggle the button icon. The button icon will change to
reflect the current connection status.

When a device is connected, its ID is sent to the TPS32 Programmer. The tool then configures and
displays the memory map based on the connected device type.

2.3  Log Panel
Figure 2-11 shows the log panel.

Figure 2-11   Log Panel

The panel displays errors, warnings, and informational events related to the operations executed by
the tool.

2.4  Clear Button
Figure 2-12 shows the clear button.

Main Window
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Figure 2-12   Clear Button

Click on the button to clear the log.

2.5  Status & Progress Bar
Figure 2-13 shows the status bar.

Figure 2-13   Status Bar

The status bar displays some connection information and progress information.

Main Window
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Option Bytes

Chapter 3  Option Bytes

The Option Bytes panel is a feature that allows users to view and modify target option bytes. Option
bytes are typically used in microcontrollers to configure various hardware options and features.

With this panel, users can see the option bytes organized into categories, making it easier to
navigate and understand their purpose. The values of these option bytes can be modified by
updating the corresponding value fields. After making the desired changes, users can click the Write
button to program and verify that the modified option bytes are correctly programmed.

Additionally, users can click the Read button at any time to refresh and display the current values of
the option bytes.

3.1  Main Page
This page provides the functionality to read and write option bytes. When the mouse hovers over a
specified label, a help prompt is displayed, as shown in Figure 3-1.

Figure 3-1   Option Bytes Page

All the option bytes configurations can be classified into three categories:

• User option: Users can configure boot mode, watchdog mode and reset behavior under low-
power mode, and more.

• Write protection option: Users can set up to four write protection areas to prevent accidental code
erasure.

NOTE: The minimum granularity of write protection is one sector (4KB in dual bank mode and
8KB in single bank mode).

• Read protection option: Users can configure two proprietary code read out protection areas or
global RDP level to l to prevent code from being read out.
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NOTE: Proprietary code read out protection (PCROP area) can be deactivated through global
RDP degrading. When pcrop1_rdp bit is set to 1 and RDP level degrades from 1 (0xBB)
to 0 (0xAA), the PCROP area will be reset to unprotected initial value and all Flash area
has been erased.

If RDP has been set to 0xCC (level 2), the device internal memory can’t be accessed
any more.

The minimum granularity of read protection are double words in dual bank mode and
four words in single bank mode.

3.2  Document Page
Figure 3-2 shows the Option Bytes document page.

Figure 3-2   Option Bytes Document

This page shows registers documentation for option bytes. For more information, refer to the
TPS325M Technical Reference Manual.

Option Bytes
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Program

Chapter 4  Program

Figure 4-1 shows the Program page.

Figure 4-1   Program Page

4.1  Memory Erasing
When connected to a target device, the memory sectors are shown in the right panel, displaying the
starting address and size of each sector.

Partial Erase
1. Locate the memory map list on the right panel, and choose the row you want to erase.
2. Click Erase Selected Sectors.

Full Erase
1. In the Erase Flash Memory area, click Select All.
2. Click Full Erase to complete the process.

NOTE: The Full Erase button will erase the whole memory, so exercise caution while using it.

4.2  Image Programming
To program a memory, follow these steps:

1. Click the Open button and select the file that you want to program.

Supported file formats are binary (.bin) and Intel hex (.hex).
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• For .bin files, assigning the correct Start Address is necessary.

NOTE: When programming a binary file, ensure the Start Address is correctly set.

• For .hex files, configuring the Start Address is not required as the programming address is
embedded within the .hex file.

2. Select the programming options:

• Skip flash erase before programming: if checked, the memory will not be erased before
programming. This option must be checked only when you are sure that the target memory is
already erased.

• Verify programming: this option reads back the programmed memory and compares it byte
by byte with the file.

• Run after programming: this option starts the application immediately after programming.

NOTE: DAPLink doesn’t support Run after programming function.

3. Click the Start Programming button to begin the programming process.

The progress bar at the bottom of the window will show the progress of the erase and
programming operations.

Program
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Memory

Chapter 5  Memory

5.1  Reading and Displaying Target Memory
This panel is used to display Flash data read back from the target MCU.

Figure 5-1   Device Memory

The table below provides descriptions of the various areas depicted in Figure 5-1.

Area No. Description

1 Indicate the start address.

2 Indicate the size of memory to read.

3 Indicate the display width.

4 Indicate the Write and Read buttons.

5 Display memory data.

5.2  Editing Memory
To edit a memory, follow these steps:

1. Double-click the cell to enter edit mode.
2. Modify the data.
3. Click outside the cell to remove focus.
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After modifying the cell, it will be displayed with a green background color, indicating that it is
marked to be written.

4. Click the Write button to write the changed data.

The progress bar at the bottom of the window will show the progress of the erase and
programming operations.

5. Once the data is successfully written, the interface will be refreshed.

Figure 5-2   Memory Edit

NOTE: Memory erase must be executed before memory program.

When using UART, 64-bit write in dual bank mode and 128-bit write in single bank mode
are supported; When using DAPLink, only 64-bit write in dual bank is supported.

Memory
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Software Installation

Chapter 6  Software Installation

6.1  Installation Procedures
1. Double-click on the installation file.

2. Read and accept the license agreement, then click Next to continue.

3. Choose the desired installation directory.
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4. Opt to create a desktop shortcut for easy access if desired.

5. Complete the installation process. Select to launch TPS32 Programmer automatically when
finished if preferred.

Software Installation
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Software Installation
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Start the TPS32 Programmer

Chapter 7  Start the TPS32 Programmer

7.1  Setup Procedures
1. Connect target board with DAPLink (CMSIS-DAP) debugger or UART0 PA1 and PA2 pins.

2. Launch the TPS32 Programmer by double-clicking its desktop shortcut.

3. Select the desired connection type and click the connect button.
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IMPORTANT NOTICE AND DISCLAIMER
Copyright© 3PEAK 2012-2023. All rights reserved.

Trademarks. Any of the 思瑞浦 or 3PEAK trade names, trademarks, graphic marks, and domain names
contained in this document /material are the property of 3PEAK. You may NOT reproduce, modify, publish,
transmit or distribute any Trademark without the prior written consent of 3PEAK.

Performance Information. Performance tests or performance range contained in this document/material
are either results of design simulation or actual tests conducted under designated testing environment. Any
variation in testing environment or simulation environment, including but not limited to testing method, testing
process or testing temperature, may affect actual performance of the product.

Disclaimer. 3PEAK provides technical and reliability data (including data sheets), design resources
(including reference designs), application or other design recommendations, networking tools, security
information and other resources "As Is". 3PEAK makes no warranty as to the absence of defects, and
makes no warranties of any kind, express or implied, including without limitation, implied warranties as to
merchantability, fitness for a particular purpose or non-infringement of any third-party’s intellectual property
rights. Unless otherwise specified in writing, products supplied by 3PEAK are not designed to be used in any
life-threatening scenarios, including critical medical applications, automotive safety-critical systems, aviation,
aerospace, or any situations where failure could result in bodily harm, loss of life, or significant property
damage. 3PEAK disclaims all liability for any such unauthorized use.
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